limit suite-sparse to 5.1.0
authorDenis Davydov <davydden@gmail.com>
Sat, 31 Mar 2018 13:53:09 +0000 (15:53 +0200)
committerDenis Davydov <davydden@gmail.com>
Sat, 31 Mar 2018 13:53:09 +0000 (15:53 +0200)
deal.II-in-Spack.md

index 0d83db3ff727afeecb718f33e133dbefd12e6fd9..17d51a68a795481f8f3f23b88c584a5d32890582 100644 (file)
@@ -97,10 +97,12 @@ packages:
     paths:
       openmpi@2.0.2%gcc@4.8.5: /apps/OpenMPI/2.0.2-gcc/
     buildable: False
+  suite-sparse:
+    version: [5.1.0]
   dealii:
     variants: +optflags~python
 ```
-Those paths are the location where external packages can be found (i.e. `<prefix>` instead of `<prefix>/bin` or `<prefix>/lib`). `providers` section essentially tells Spack which packages to use to satisfy virtual dependencies such as `MPI`, `BLAS`, `LAPACK`, `ScaLAPACK`, etc.
+Those paths are the location where external packages can be found (i.e. `<prefix>` instead of `<prefix>/bin` or `<prefix>/lib`). `providers` section essentially tells Spack which packages to use to satisfy virtual dependencies such as `MPI`, `BLAS`, `LAPACK`, `ScaLAPACK`, etc. Here we also limit version of `suite-sparse` to `5.1.0` as we build with `gcc@4.8.5` whereas `5.2.0` requires at least `gcc@4.9`. 
 
 (4) Now install deal.II:  `spack install dealii@8.5.1`.
 

In the beginning the Universe was created. This has made a lot of people very angry and has been widely regarded as a bad move.

Douglas Adams


Typeset in Trocchi and Trocchi Bold Sans Serif.